quinta-feira, 13 de julho de 2017

Criando um USB bootável para o Ubuntu 17.04

Para quem não quer gravar um CD ou DVD com o sistema operacional, pode estar utilizando uma mídia USB.

Realize o download do Rufus https://rufus.akeo.ie/?locale

1) Execute o Rufus > com o pen drive inserido selecione:

Tipo de partição: Partição MBR para BIOS ou UEFI

Sistema de arquivos: FAT32

Tamanho do cluster: 4096 bytes

Insira um nome para o volume: Ubuntu 17.04 (opcional)

Em criar disco bootável com: selecione Imagem ISO e localize o ISO do Ubuntu (que você fez o download previamente)

2) Clique em Iniciar

clip_image002

3) Selecione Gravar no modo imagem ISO > OK

clip_image003

4)  Clique em Fechar.

clip_image002

Pen drive bootável pronto! Agora é só dar o boot pelo prive e instalar seu Linux.

5

quarta-feira, 5 de julho de 2017

Debian 6 no Hyper-V do Windows Server 2016 – Caso Placa de rede

Debian no Hyper-V do Windows Server 2016 – Caso Placa de rede

Já faz um tempo que alguns amigos da área quando entram em contato com situações envolvendo Linux no Hyper-V em muito dos casos é sempre a questão da placa de rede.

O caso hoje envolve o Debian, aliás como todos sabem é a minha distro preferida. Vamos lá:

1) Ao instalar o Debian no Hyper-V pode deixar a placa de rede padrão, não há nesse caso a necessidade de adicionar a o adaptador de rede legacy (herdado).

2) Se durante a instalação do Debian a placa de rede não foi reconhecida você apenas terá o problema de não poder já atualizar alguns pacotes, porém nada que não possa ser realizado posteriormente.

3) Ao concluir a instalação abra o VI ou Nano e acesse como root:

/etc/network/interfaces

Adicione: (vamos exemplificar os endereços IP, máscara, gateway e DNS)

auto eth0

iface eth0 inet static

address 192.168.1.240

netmask 255.255.255.0

gateway 192.168.1.1

dns-nameservers 8.8.8.8

Grave as alterações.

clip_image002[6]

4) Suba a interface com o comando

ifup eth0

clip_image004[6]

5) Digite ifconfig e a placa de rede está funcionando!

Conforme bem observado pelo meu amigo @flavioformata o ifconfig não funciona nas versões mais novas e para isso terá que instalar o net-tools.

clip_image006[6]